Uploading new logo

I am having trouble uploading my new logo.

It shows OK when I upload it, tells me its uploaded sucessfully, but on the booking calender and the preview there is just a placeholder. Then when I go back to settings the logo has disappeared. I’ve tried refreshing the page and clearing the cache. Tried it on different devices and different browsers but still it won’t work. The old one was fine. I’ve tried different file formats (png and jpg). Tried adjusting the max pixel size. Nothing works.

Hi @Shirley_B,

Ok this is a strange one. Could you please send an email to [email protected]? This is purely so I know the email address for your account and can investigate.

Thanks, James


There was an intermittent problem there, sorry for any inconvenience caused. You should be able to upload your logo no problem now.

Thanks, James

Hi James, sorry to jump on this thread. I’m a new user and have just set up my calendar but I cannot upload my logo at all. Does it have to be of a certain size/dimensions?
Thank you in advance for your kind help.